MOSTValidator Incompatibilities

Hello!

As the Simbad and Vizier services recently upgraded their interfaces, MOSTValidator is now incompatible with the new systems and cannot be used to search for targets.

Please bear with us; we are rolling out a new version of the software soon.

Regards,

Varun

Powered by Drupal - Design by artinet